Features Not Supported in SuiteScript 2.0

As NetSuite is gaining popularity all over the world, they are also offering various features and improvement every year. Earlier, the common issue we leverage about the SuiteScript 1.0, however during release of 2015 version 2 introduced this SuiteScript 2.0 to increase the efficiency of your custom scripts and others. SuiteScript 2.0 also has introduced more modular.

However still some features not Supported in SuiteScript 2.0

  • Core Plug-ins
  • SSP scripts
  • SuiteCommerce Advanced

You need to attention towards some of the below recommendation

  • Your script (entry point script and supporting library scripts) must use either SuiteScript 1.0 or SuiteScript 2.0. You cannot use APIs from both versions in one script.
  • You can, however, have multiple scripts that use different SuiteScript versions. These can be deployed in the same account, in the same SuiteApp, and on the same record.
  • The map/reduce script type is a new functionality introduced with SuiteScript 2.0. You cannot use nlapiScheduleScript(scriptId, deployId, params) to schedule a Map/Reduce script.

Suitescript 2.0 is in no doubt a huge leap ahead of SuiteScript 1.0. There are of course long way to go, but overall, we highly recommend moving what you’ve got over. In the coming days only SuiteScript 2.0 will be supported by NetSuite.

Related Post

Leave a Reply